AFNI Message Board

History of AFNI updates  

|
February 09, 2018 11:13AM
Hi all,

I am working on using @toMNI_Qwarpar to create a nonlinearly warped atlas for my dataset. I have run @toMNI_Awarp successfully on each individual dataset, and am trying to run @toMNI_Qwarpar in the directory created by @toMNI_Awarp.

However, when I run @toMNI_Qwarpar I receive this fatal error message and the script eventually dies:

[williamss@node10 OASESatlas_2009]$ ./OASES_qwarp.sh

========== @toMNI_Qwarp: Compute A level mean (affine) ==========

++ 3dMean: AFNI version=AFNI_17.0.18 (Mar 29 2017) [64-bit]

========== @toMNI_Qwarp: Compute B level (minimum patch = 101) ==========

=== Processing 48 datasets in 8 jobs
=== Bottom index list = 1 7 13 19 25 31 37 43
=== Top index list = 6 12 18 24 30 36 42 48
[1] 22559
205_MPRAGE_strip_uni+tlrc.HEAD 206_MPRAGE_strip_uni+tlrc.HEAD 207_MPRAGE_strip_uni+tlrc.HEAD 217_MPRAGE_strip_uni+tlrc.HEAD 222_MPRAGE_strip_uni+tlrc.HEAD 224_MPRAGE_strip_uni+tlrc.HEAD
++ OpenMP thread count = 1
++ 3dQwarp: AFNI version=AFNI_17.0.18 (Mar 29 2017) [64-bit]
++ Authored by: Zhark the (Hermite) Cubically Warped
** FATAL ERROR: base-source dataset grid mismatch sad smiley : try the -resample option


This goes on and pops up for each file in the dataset.
I tried running:
3dinfo -same_grid DSET1 DSET2 and 3dinfo -orient -d3 -nijk -o3 -space -prefix DSET1 DSET2 to compare my individual volumes to the base template I'm using, per suggestions I found in other message boards, and I get the following outcomes:

[williamss@login01 OASESatlas_2009]$ 3dinfo -same_grid MNI152_T1_2009c+tlrc.HEAD 206_MPRAGE_strip_uni+tlrc.HEAD
1
1
[williamss@login01 OASESatlas_2009]$ 3dinfo -orient -d3 -nijk -o3 -space -prefix MNI152_T1_2009c+tlrc.HEAD 206_MPRAGE_strip_uni+tlrc.HEAD
LPI -1.000000 -1.000000 1.000000 8530021 96.000000 132.000000 -78.000000 MNI MNI152_T1_2009c
LPI -1.000000 -1.000000 1.000000 8530021 96.000000 132.000000 -78.000000 MNI 206_MPRAGE_strip_uni

These outcomes are similar for my other volumes as well, so it seems they are all on the same grid, as they should be.

I also tried adding -resample to 3dQwarp in the B level warp and still received the same error.

The version of AFNI currently being used is Mar 29 2017 (Version AFNI_17.0.18) as I'm working off a high performance cluster. If anyone thinks it would help I can see if a newer version can be added.

Thanks in advance. Any help you can provide would be appreciated!

Best,
Sam Williams



Edited 1 time(s). Last edit at 02/11/2018 10:55AM by sewilliams.
Subject Author Posted

@toMNI_Qwarpar - FATAL ERROR: base-source dataset grid mismatch

sewilliams February 09, 2018 11:13AM



Sorry, only registered users may post in this forum.

Click here to login