AFNI Message Board

History of AFNI updates  

|
October 07, 2020 03:25PM
I have a similar problem.
When I run the three suggested commands, I get:

~: R RHOME
/Library/Frameworks/R.framework/Resources

~: ls -l /Library/Frameworks/R.framework/Versions/*/Resources/lib/libR.dylib
-rwxrwxr-x 1 root admin 4071728 Jun 23 19:50 /Library/Frameworks/R.framework/Versions/4.0/Resources/lib/libR.dylib
-rwxrwxr-x 1 root admin 4071728 Jun 23 19:50 /Library/Frameworks/R.framework/Versions/Current/Resources/lib/libR.dylib

~: 3dMVM -help
updating R_LD_LIBRARY_PATH ...

oo Warning:
Failed to load R_io.so with this error message:

Error in dyn.load(ll) :
unable to load shared object '/Users/knutsonk/abin/R_io.so':
dlopen(/Users/knutsonk/abin/R_io.so, 6): Library not loaded: /sw/Library/Frameworks/R.framework/Versions/3.6/Resources/lib/libR.dylib
Referenced from: /Users/knutsonk/abin/R_io.so
Reason: image not found
Calls: source ... withVisible -> eval -> eval -> set_R_io -> dyn.load
Execution halted

Any help with this? Thanks.
Subject Author Posted

R library issue while trying to run 3dLME

BrainFood September 08, 2020 10:08AM

Re: R library issue while trying to run 3dLME

rick reynolds September 10, 2020 10:16AM

Re: R library issue while trying to run 3dLME

BrainFood September 15, 2020 04:00PM

Re: R library issue while trying to run 3dLME

rick reynolds October 07, 2020 02:07PM

Re: R library issue while trying to run 3dLME

krisknut October 07, 2020 03:25PM

Re: R library issue while trying to run 3dLME

rick reynolds October 07, 2020 04:02PM

Re: R library issue while trying to run 3dLME

user.1124 June 08, 2021 12:27PM

Re: R library issue while trying to run 3dLME

Gang June 09, 2021 05:28PM



Sorry, only registered users may post in this forum.

Click here to login