AFNI Message Board

History of AFNI updates  

|
April 19, 2021 06:21PM
Hi, Rosella-

Jumping to the bottom section, " summary, please fix:", there is one primary thing to address in the sense of "fix" (the shell note is just so you are aware):
* missing R packages (see rPkgsInstall)
Zooming up to the R package install section, indeed we see in more detail:
checking for R packages...
rPkgsInstall -pkgs ALL -check : FAILURE

oo Warning:
These packages are not installed on the computer: afex!
These packages are not installed on the computer: phia!
These packages are not installed on the computer: lmerTest!
These packages are not installed on the computer: brms!
These packages are not installed on the computer: metafor!
So, a problem with some R package dependencies.

Looking at this line in your system check:
R version : R version 3.1.1 (2014-07-10) -- "Sock it to Me"
... we get the R version number, which is too old to support these newer packages. You would have to update your R base version to be able to install the remaining dependencies. In practice, this means removing/uninstalling R completely (so no stale packages get left and cause confusion with the updated R), and then install all the AFNI-required R packages with "rPkgsInstall -pkgs ALL", as well as any other R packages you might want.

Note that the R packages are for Gang's group analysis programs, so you might not need those right now (perhaps down the road), so you could with some of this later, depending on what you want to analyze/look at now with AFNI.

--pt
Subject Author Posted

AFNI installation

rosella April 19, 2021 10:56AM

Re: AFNI installation

ptaylor April 19, 2021 06:21PM



Sorry, only registered users may post in this forum.

Click here to login