AFNI Message Board

History of AFNI updates  

|
June 10, 2021 03:45AM
Hi all,

I've been using @animal_warper with much success for a while now, but yesterday I encountered a weird error.

The first *ERROR* in the output reads:
** FATAL ERROR: 3dQwarp fails :: source has 0 nonzero voxels (<100)

I backtraced this and it seems that things go wrong at a an early 3dAllineate step for affine registration. The 'shft' and 'psift' volumes get generated in the 'intermediate' folder and look ok, but the 'pshift_al2std' and 'shft_aff' are empty files and everything after that naturally fails. In the 'awpy_SUBJECT_pshft' folder the 'anat.nii' file exists, but it's empty (all zeros).

So, I went back to the 3dAllineate step that generates the 'shft_aff' and ran it manually:
3dAllineate -base NMT_v2.0_sym.nii.gz -source *_shft.nii.gz -prefix *_shft_aff.nii.gz

When I look at the files involved, the *_shft.nii.gz has moved away from the NMT volume compared to the original single-subject input. The *_pshft.nii.gz does appear center-aligned, but the resulting *_shft_aff.nii.gz is somewhere in between the original and the *_shft.nii.gz, re-gridded to NMT and thus mostly empty.

Things I tried:
- manually aligning (translate/rotate) the single-subject to the NMTv2 before running @animal_warper so they start off close >> same results
- updated afni binaries >> same result
- ran with -keep_temp option to try to pinpoint the problem
- tried a volume that previously completed >> same error >> this is particularly confusing; perhaps some other update on the system is causing problems? But what?

I could not attached the log-file as the site wouldn't allow txt, but here it is.

Any leads on where to look next?
Subject Author Posted

@animal_warper suddenly fails

ChrisKlink June 10, 2021 03:45AM

Re: @animal_warper suddenly fails

ChrisKlink June 10, 2021 12:30PM

Re: @animal_warper suddenly fails

ptaylor June 10, 2021 06:33PM

Re: @animal_warper suddenly fails

ChrisKlink June 11, 2021 08:57AM

Re: @animal_warper suddenly fails Attachments

ChrisKlink June 11, 2021 12:31PM

Re: @animal_warper suddenly fails

ChrisKlink June 18, 2021 02:39PM

Re: @animal_warper suddenly fails

ptaylor June 21, 2021 09:20AM



Sorry, only registered users may post in this forum.

Click here to login