AFNI Message Board

History of AFNI updates  

|
March 28, 2017 07:05PM
So when I try to run the code to install R

rPkgsInstall -pkgs ALL

I get the following error

oo Warning:
Failed to load R_io.so with this error message:

Error in dyn.load(ll) :
unable to load shared object '/home/nheugel/abin/R_io.so':
libXp.so.6: cannot open shared object file: No such file or directory
Calls: source ... withVisible -> eval -> eval -> set_R_io -> dyn.load
Execution halted


Poking around seems to indicate that libXp doesn't exist on 16.04 anymore.


running afni_system_check.py -check_all


-------------------------------- general ---------------------------------
architecture: 64bit ELF
system: Linux
release: 4.4.0-66-generic
version: #87-Ubuntu SMP Fri Mar 3 15:29:05 UTC 2017
distribution: Ubuntu 16.04 xenial
number of CPUs: 64
apparent login shell: tcsh
shell RC file: .cshrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni : /home/nheugel/abin/afni
afni version : afni: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory
:
AFNI_version.txt : AFNI_17.0.17, linux_openmp_64, Mar 27 2017
which python : /usr/bin/python
python version : 2.7.12
which R : /usr/bin/R
R version : R version 3.3.3 (2017-03-06) -- "Another Canoe"
which tcsh : /bin/tcsh

instances of various programs found in PATH:
afni : 1 (/home/nheugel/abin/afni)
R : 1 (/usr/bin/R)
python : 1 (/usr/bin/python2.7)
python2 : 1 (/usr/bin/python2.7)
python3 : 1 (/usr/bin/python3.5)


testing ability to start various programs...
afni : FAILURE
afni: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory
suma : FAILURE
suma: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory
3dSkullStrip : FAILURE
3dSkullStrip: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory
uber_subject.py : success
3dAllineate : FAILURE
3dAllineate: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory
3dRSFC : FAILURE
3dRSFC: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory
SurfMesh : FAILURE
SurfMesh: error while loading shared libraries: libXp.so.6: cannot open shared object file: No such file or directory

checking for R packages...
rPkgsInstall -pkgs ALL -check : FAILURE
Error in dyn.load(ll) :
unable to load shared object '/home/nheugel/abin/R_io.so':
libXp.so.6: cannot open shared object file: No such file or directory
Calls: source ... withVisible -> eval -> eval -> set_R_io -> dyn.load
Execution halted

checking for $HOME files...
.afnirc : found
.sumarc : missing
.afni/help/all_progs.COMP : missing

------------------------------ python libs -------------------------------
++ module 'PyQt4' found at /usr/lib/python2.7/dist-packages/PyQt4
++ module loaded: PyQt4

-------------------------------- env vars --------------------------------
PATH = /bin:/usr/bin:/usr/X11R6/bin:/usr/local/bin:/home/nheugel/abin

PYTHONPATH =
R_LIBS = /home/nheugel/R

LD_LIBRARY_PATH =
DYLD_LIBRARY_PATH =
DYLD_FALLBACK_LIBRARY_PATH =

------------------------------ data checks -------------------------------
data dir : missing AFNI_data6
data dir : missing AFNI_demos
data dir : missing suma_demo
data dir : missing afni_handouts
atlas : found TT_N27+tlrc under /home/nheugel/abin

------------------------------ OS specific -------------------------------
which yum : /usr/bin/yum
yum version : 3.4.3
which apt-get : /usr/bin/apt-get
apt-get version : apt 1.2.19 (amd64)

have Ubuntu system: Ubuntu 16.04 xenial

========================= summary, please fix: =========================
* AFNI programs show FAILURE
* missing R packages (see rPkgsInstall)
* consider running "suma -update_env" for .sumarc
* consider running: apsearch -update_all_afni_help
* insufficient data for AFNI bootcamp




seems to confirm that the issue seems to be the R library. I have found ways to download and install R without libXp, but I don't know how to interface that with ANFI so I can run the program. Any help would be appreciated
Subject Author Posted

Can't install R on Ubuntu 16.04

nheugel March 28, 2017 07:05PM

Re: Can't install R on Ubuntu 16.04

ptaylor March 28, 2017 10:14PM

Re: Can't install R on Ubuntu 16.04

nheugel March 29, 2017 11:02AM

Re: Can't install R on Ubuntu 16.04

ptaylor March 29, 2017 11:28AM

Re: Can't install R on Ubuntu 16.04

nheugel March 29, 2017 11:59AM

Re: Can't install R on Ubuntu 16.04

yl148 August 07, 2018 05:57PM

Re: Can't install R on Ubuntu 16.04

rick reynolds August 09, 2018 09:12AM

Re: Can't install R on Ubuntu 16.04

rosaann August 13, 2018 08:40AM

Re: Can't install R on Ubuntu 16.04

ptaylor August 13, 2018 09:23AM



Sorry, only registered users may post in this forum.

Click here to login