AFNI Message Board

History of AFNI updates  

|
June 10, 2021 06:23PM
Thanks for sending that.

I don't think this is a Python issue.

*Something* is funny with how the options are being read in. The reason that the "Bad drive" occurs is because "-do_clean" gets inserted where it shouldn't, and the option to insert a value at that location is not used.

Additionally, comparing your terminal output to mine, I see that even this information is not being interpreted correctly: "-ulay_range_nz 0 1300". Basically, that should lead to this line in the output:
++ Ulay to be visualized within user range:
   [0, 1300]
... because the ulay range is being explicitly stated. However, in yours, it looks like this:
++ Ulay to be visualized within user range:
[0%, 98%] -> [0.000000, 1367.000000]
... which is the default behavior if the utilized option were not being used.

*So*, this is mysterious. And somehow a shell issue, I think.

I made an update to @chauffeur_afni that will allow some more verbose output. Could you please go to the same Bootcamp dir, AFNI_data6/FT_analysis/FT, and copy+paste the following:
curl -O https://raw.githubusercontent.com/afni/afni/f72a8d64acba0a26eb4292bdb326bf300bae2615/src/scripts_install/%40chauffeur_afni

Then, can you run these *slightly* modified chauffeur commands (each now contains "-echo" as the first option, and also they are executed with "tcsh ./@chauffeur_afni ..." to specify that this specific version of the program should be used), and save the output of each to a log in the same way as before (redirecting, appropriate to what shell you are running)?:
tcsh ./@chauffeur_afni  -echo                                 \
    -ulay FT_anat+orig.HEAD                       \
    -olay FT_anat+orig.HEAD                       \
    -ulay_range_nz 0 1300                         \
    -func_range    1300                           \
    -box_focus_slices AMASK_FOCUS_ULAY            \
    -cbar gray_scale                              \
    -pbar_posonly                                 \
    -pbar_saveim TEST1.pbar.jpg                   \
    -pbar_comm_range "test1 text"                  \
    -pbar_for dset                                \
    -prefix      TEST1                            \
    -save_ftype JPEG                              \
    -blowup 4                                     \
    -opacity 9                                    \
    -montx 7 -monty 1                             \
    -montgap 1 -montcolor black                   \
    -set_xhairs OFF -label_mode 1 -label_size 3   \
    -do_clean

tcsh ./@chauffeur_afni -echo                                  \
    -ulay FT_anat+orig.HEAD                       \
    -olay FT_anat+orig.HEAD                       \
    -ulay_range_nz 0 1300                         \
    -func_range    1300                           \
    -box_focus_slices AMASK_FOCUS_ULAY            \
    -cbar gray_scale                              \
    -pbar_posonly                                 \
    -pbar_comm_range "test2 text"                 \
    -pbar_for dset                                \
    -prefix      TEST2                            \
    -save_ftype JPEG                              \
    -blowup 4                                     \
    -opacity 9                                    \
    -montx 7 -monty 1                             \
    -montgap 1 -montcolor black                   \
    -set_xhairs OFF -label_mode 1 -label_size 3   \
    -do_clean
These outputs will be verbose. Could you please email me the text files of them (I will email you so you have my email).

Thanks,
pt
Subject Author Posted

APQC output issues Attachments

mjss June 07, 2021 05:35PM

Re: APQC output issues

ptaylor June 07, 2021 05:56PM

Re: APQC output issues

mjss June 07, 2021 08:49PM

Re: APQC output issues

ptaylor June 07, 2021 09:53PM

Re: APQC output issues

mjss June 08, 2021 10:10AM

Re: APQC output issues

mjss June 08, 2021 10:11AM

Re: APQC output issues

mjss June 08, 2021 06:01PM

Re: APQC output issues

ptaylor June 09, 2021 05:02PM

Re: APQC output issues

mjss June 10, 2021 11:49AM

Re: APQC output issues

ptaylor June 10, 2021 06:23PM



Sorry, only registered users may post in this forum.

Click here to login