AFNI Message Board

History of AFNI updates  

|
April 18, 2022 05:04PM
yes, I have python installed via miniconda3

-------------------------------- general ---------------------------------
architecture:         64bit 
system:               Darwin
release:              21.4.0
version:              Darwin Kernel Version 21.4.0: Mon Feb 21 20:34:37 PST 2022; root:xnu-8020.101.4~2/RELEASE_X86_64
distribution:         10.16
number of CPUs:       6
apparent login shell: zsh
shell RC file:        .zshrc (exists)

--------------------- AFNI and related program tests ---------------------
which afni           : /Users/andrewlynn/abin/afni
afni version         : Precompiled binary macos_10.12_local: Dec  3 2021 
                     : AFNI_21.3.10 'Trajan'
AFNI_version.txt     : AFNI_21.3.10, macos_10.12_local, Dec 03 2021
which python         : /Users/andrewlynn/miniconda3/bin/python
python version       : 3.9.7
which R              : /usr/local/bin/R
R version            : R version 3.6.3 (2020-02-29) -- "Holding the Windsock"
which tcsh           : /bin/tcsh

instances of various programs found in PATH:
    afni    : 1   (/Users/andrewlynn/abin/afni)
    R       : 1   (/Library/Frameworks/R.framework/Versions/3.6/Resources/bin/R)
    python  : 1   (/Users/andrewlynn/miniconda3/bin/python3.9)
    python2 : 0 
    python3 : 3 
      /Users/andrewlynn/miniconda3/bin/python3.9
      /Library/Frameworks/Python.framework/Versions/3.10/bin/python3.10
      /usr/bin/python3

** have python3 but not python2

testing ability to start various programs...
    afni                 : success
    suma                 : success
    3dSkullStrip         : success
    uber_subject.py      : success
    3dAllineate          : success
    3dRSFC               : success
    SurfMesh             : success
    3dClustSim           : success
    3dMVM                : success

checking for R packages...
    rPkgsInstall -pkgs ALL -check : success

R RHOME : /Library/Frameworks/R.framework/Resources

checking for $HOME files...
    .afnirc                   : found
    .sumarc                   : found
    .afni/help/all_progs.COMP : found

------------------------------ python libs -------------------------------
** failed to load module PyQt4
-- PyQt4 is no longer needed for an AFNI bootcamp

** failed to load module matplotlib.pyplot
-- matplotlib.pyplot is not required, but is desirable

-- python binaries under /usr/local/bin:
    /usr/local/bin/python3 (sym link to /Library/Frameworks/Python.framework/Versions/3.10/bin/python3.10)
    /usr/local/bin/python3.9 (sym link to /usr/local/Cellar/python@3.9/3.9.6/Frameworks/Python.framework/Versions/3.9/bin/python3.9)

-------------------------------- env vars --------------------------------
PATH = /Users/andrewlynn/miniconda3/bin:/Users/andrewlynn/miniconda3/condabin:/Library/Frameworks/Python.framework/Versions/3.10/bin:/Applications/freesurfer/7.1.1/bin:/Applications/freesurfer/7.1.1/fsfast/bin:/Applications/freesurfer/7.1.1/mni/bin:/usr/local/bin:/usr/bin:/bin:/usr/sbin:/sbin:/opt/X11/bin:/Library/Apple/usr/bin:/Users/andrewlynn/abin

PYTHONPATH = 
R_LIBS = 
LD_LIBRARY_PATH = 
zsh compinit: insecure directories, run compaudit for list.
Ignore insecure directories and continue [y] or abort compinit [n]? y
DYLD_LIBRARY_PATH (sub-shell) = :/opt/X11/lib/flat_namespace
zsh compinit: insecure directories, run compaudit for list.
Ignore insecure directories and continue [y] or abort compinit [n]? DYLD_FALLBACK_LIBRARY_PATH (sub-shell) = 

------------------------------ data checks -------------------------------
data dir : missing AFNI_data6
data dir : missing AFNI_demos
data dir : missing suma_demo
data dir : missing afni_handouts
atlas    : found TT_N27+tlrc  under /Users/andrewlynn/abin

------------------------------ OS specific -------------------------------
XQuartz version      : 2.8.1

which brew           : /usr/local/bin/brew
brew version         : Homebrew 3.2.7

++ found PyQt4 under /usr/local/lib/python2.7/site-packages
** warning: have brew? PyQt4, but non-brew python /Users/andrewlynn/miniconda3/bin/python
-- consider installing gcc under homebrew
-- consider installing glib under homebrew
++ found 1 dylib files under '/opt/X11/lib/flat_namespace'
   -- found 'libXt' dylib files:
      /opt/X11/lib/flat_namespace/libXt.6.dylib
-- recent OS X, cheating to check DYLD_LIBRARY_PATH in cur shell 'zsh'...
zsh compinit: insecure directories, run compaudit for list.
Ignore insecure directories and continue [y] or abort compinit [n]? y
++ found evar DYLD_LIBRARY_PATH = :/opt/X11/lib/flat_namespace
-- recent OS X, cheating to check DYLD_LIBRARY_PATH in shell 'tcsh'...
** env var DYLD_LIBRARY_PATH not set to contain /opt/X11/lib/flat_namespace

=========================  summary, please fix:  =========================
*  just be aware: login shell 'zsh', but our code examples use 'tcsh'
*  insufficient data for AFNI bootcamp
   (see "Prepare for Bootcamp" on install pages)
*  please set DYLD_LIBRARY_PATH to /opt/X11/lib/flat_namespace in tcsh
Subject Author Posted

calling afni python scrips through MATLAB

aclynn11 April 18, 2022 03:31PM

Re: calling afni python scrips through MATLAB

ptaylor April 18, 2022 04:16PM

Re: calling afni python scrips through MATLAB

Daniel Glen April 18, 2022 04:24PM

Re: calling afni python scrips through MATLAB

aclynn11 April 18, 2022 04:48PM

Re: calling afni python scrips through MATLAB

ptaylor April 18, 2022 05:01PM

Re: calling afni python scrips through MATLAB

aclynn11 April 18, 2022 05:04PM

Re: calling afni python scrips through MATLAB

ptaylor April 18, 2022 05:16PM

Re: calling afni python scrips through MATLAB

aclynn11 April 18, 2022 05:08PM

Re: calling afni python scrips through MATLAB

ptaylor April 18, 2022 05:17PM



Sorry, only registered users may post in this forum.

Click here to login