AFNI Message Board

History of AFNI updates  

|
September 08, 2020 10:08AM
Hi all,

Noticed a couple of similar posts but they were older. Stumbled on a problem when trying to run 3dLME, seems that R libraries are not compatible. I've uninstalled and re-installed R to no avail. Hope I've included the relevant info below to help diagnose the problem! Please let me know what other info might be helpful. Many thanks for your help!


1. SCRIPT USED and output with error:

[dk12r4003mac4:~/abin] user% /Volumes/LBM_HallKD/Data/Scripts/@3dLME_AllFoodXdiet.sh
set nonomatch
set mask = /Volumes/LBM_HallKD/Data/CFR_data/02-anatomical_masks/reward_circuit_mask_resampled+tlrc
set out_dir=/Volumes/LBM_HallKD/Data/CFR_data/

set prefix = 3dLME

cd /Volumes/LBM_HallKD/Data/CFR_data/

3dLME
-prefix 3dLME -jobs 4
-mask /Volumes/LBM_HallKD/Data/CFR_data/02-anatomical_masks/reward_circuit_mask_resampled+tlrc
-model 1
-ranEff ~1
-corStr order : AR1
-SS_type 3
-num_glt 3
-gltLabel 1 LFvLC -gltCode 1 diet : 1*lowfat - 1*lowcarb
-gltLabel 2 LFvB -gltCode 2 diet : 1*lowfat - 1*baseline
-gltLabel 3 LCvB -gltCode 3 diet : 1*lowcarb - 1*baseline
-num_glf 1
-glfLabel 1 dietcond -glfCode 1 diet : 1*lowcarb & 1*lowfat & 1*baseline
-dataTable Subj diet InputFile s307 baseline /Volumes/LBM_HallKD/Data/CFR_data/stats_files/psc_stats_files/func.o_s307_pscr_d1.psc.Composite.AM2_with_GAM.blur6mm.scale+tlrc.HEAD[ples_composite#0_Coef]

[… file list truncated for brevity…]

updating R_LD_LIBRARY_PATH ...

oo Warning:
Failed to load R_io.so with this error message:

Error in dyn.load(ll) :
unable to load shared object '/Users/darceyvl/abin/R_io.so':
dlopen(/Users/darceyvl/abin/R_io.so, 6): Library not loaded: /sw/Library/Frameworks/R.framework/Versions/3.6/Resources/lib/libR.dylib
Referenced from: /Users/darceyvl/abin/R_io.so
Reason: image not found
Calls: source ... withVisible -> eval -> eval -> set_R_io -> dyn.load
Execution halted


2. MacOS: Mojave 10.14.6

3. AFNI version: Precompiled binary macos_10.12_local: Jul 5 2020 (Version AFNI_20.2.00 'Aulus Vitellius')

4. R software

R was installed using the [afni.nimh.nih.gov]

The first three lines from the output of the command line at the terminal: R --version

R version 3.6.3 (2020-02-29) -- "Holding the Windsock"
Copyright (C) 2020 The R Foundation for Statistical Computing
Platform: x86_64-apple-darwin15.6.0 (64-bit)

Attempt to update R Packages (via terminal):

>>sudo rPkgsInstall -pkgs ALL
updating R_LD_LIBRARY_PATH ...

oo Warning:
Failed to load R_io.so with this error message:

Error in dyn.load(ll) :
unable to load shared object '/Users/darceyvl/abin/R_io.so':
dlopen(/Users/darceyvl/abin/R_io.so, 6): Library not loaded: /sw/lib/libjpeg.9.dylib
Referenced from: /Users/darceyvl/abin/R_io.so
Reason: Incompatible library version: R_io.so requires version 13.0.0 or later, but libjpeg.9.dylib provides version 12.0.0
Calls: source ... withVisible -> eval -> eval -> set_R_io -> dyn.load
Execution halted
[dk12r4003mac4:~/abin] darceyvl% touch hello
[dk12r4003mac4:~/abin] darceyvl% ls hello
hello


-->Error in R (via R conosole):

> first.in.path <- function(file) {
+ ff <- paste(strsplit(Sys.getenv('PATH'),':')[[1]],'/', file, sep='')
+ ff<-ff[lapply(ff,file.exists)==TRUE];
+ #cat('Using ', ff[1],'\n');
+ return(gsub('//','/',ff[1], fixed=TRUE))
+ }
> source(first.in.path('AFNIio.R'))
Error in if (file == "") { : missing value where TRUE/FALSE needed
>
> first.in.path <- function(file) {
+ ff <- paste(strsplit(Sys.getenv('PATH'),':')[[1]],'/', file, sep='')
+ ff<-ff[lapply(ff,file.exists)==TRUE];
+ #cat('Using ', ff[1],'\n');
+ return(gsub('//','/',ff[1], fixed=TRUE))
+ }
> source(first.in.path('AFNIio.R'))
Error in if (file == "") { : missing value where TRUE/FALSE needed
>
> (ll <- find.in.path('R_io.so'))
Error in find.in.path("R_io.so") : could not find function "find.in.path"
> dyn.load(ll)
Error in dyn.load(ll) : object 'll' not found
Subject Author Posted

R library issue while trying to run 3dLME

BrainFood September 08, 2020 10:08AM

Re: R library issue while trying to run 3dLME

rick reynolds September 10, 2020 10:16AM

Re: R library issue while trying to run 3dLME

BrainFood September 15, 2020 04:00PM

Re: R library issue while trying to run 3dLME

rick reynolds October 07, 2020 02:07PM

Re: R library issue while trying to run 3dLME

krisknut October 07, 2020 03:25PM

Re: R library issue while trying to run 3dLME

rick reynolds October 07, 2020 04:02PM

Re: R library issue while trying to run 3dLME

user.1124 June 08, 2021 12:27PM

Re: R library issue while trying to run 3dLME

Gang June 09, 2021 05:28PM



Sorry, only registered users may post in this forum.

Click here to login